Home > ほんとだすらい > 転ばぬ先の杖− bashのshellshock対応

転ばぬ先の杖− bashのshellshock対応

パソコンのログインシェルですが、
最初に触ったのが「tcsh」で、以来ずーっと「tcsh」です。
macでも、もちろん「tcsh」を使ってます。
はい、おっさんです。

先日、
「bash」に、任意のコードが実行出来る「shellshock」と言う脆弱性
というか不具合が見つかりました。

bash_shellshock
「vnlnerable」とechoが返されている所が、実は任意のコードが実行できる部分です。

OSX_bash_update_1.0

Appleより、「bash」の「shellshock」対策が施されたupdateが公開されています。
今の利用法では、僕のiMacが「shellshock」による攻撃を受けることはまずないのですが、
一応、対策しておきます。

bash_shellshock_updated

不具合は、解消されました。

コメント:0

コメントフォーム
Remember personal info

*

Home > ほんとだすらい > 転ばぬ先の杖− bashのshellshock対応

楽天 トラベル
Recent Entry
Comments
feeds

Return to page top